SPIM Registration

QR for this page

From Fiji

Jump to: navigation, search
Selective Plane Illumination Microscopy Registration (ImageJ)
Author Stephan Preibisch, Stephan Saalfeld, Johannes Schindelin, Pavel Tomancak
Maintainer Stephan Preibisch
File SPIM_Registration.jar
Initial release February 2010
Latest version June 2012
Category SPIM Registration
Website Stephan Preibisch's homepage


Citation

Please note that the SPIM registration plugin available through Fiji, is based on a publication. If you use it successfully for your research please be so kind to cite our work:

  • S. Preibisch, S. Saalfeld, J. Schindelin and P. Tomancak (2010) "Software for bead-based registration of selective plane illumination microscopy data", Nature Methods, 7(6):418-419. Webpage PDF Supplement

For technical details about the registration method and SPIM imaging see SPIM Registration Method.

Introduction & Overview

Selective Plane Illumination Microscopy (SPIM, Science, 305(5686):1007-9) allows in toto imaging of large specimens by acquiring image stacks from multiple angles. However, to realize the full potential of these acquisitions the data needs to be reconstructed:

We developed several algorithms for the registration and fusion of multi-angle SPIM acquisitions. This plugin collection allows you to reconstruct an isotropic output image from several input images, called views. This process can be applied to timelapse acquisitions as well. The complete reconstruction process is split into two parts, where you have several choices for each step:

  • Multi-view registration: Aligns all views of the dataset

    • Bead-based registration: Uses flourescent beads to achieve the alignment. This method is very fast and solves timeseries registration, but relies on the incorporation of fluorescent beads. The plugin can be found in Plugins->SPIM Registration->Bead-based registration.
    • Segmentation-based registration: Uses structures within the sample like nuclei to achieve registration. It is slower and timelapse registration might be a sample dependent problem, but does not require any special sample prepration.
  • Multi-view fusion: Computes the output image(s) based on the registration results

    • Multi-view fusion: Performs a weighted average fusion of the dataset, which includes blending and/or content-based weightening. The plugin can be found in Plugins->SPIM Registration->Multi-view fusion.
    • Multi-view deconvolution: Performs a multi-view deconvolution of the dataset which requires an estimation of the point spread function.


Please note: the SPIM registration has been rewritten and now replaces the "old" plugin collection (Registration, Advanced Registration, MultiChannel Registration) which has been moved to the deprecated folder. For information regarding these outdated plugins please refer to this page.

Detailed tutorials

SPIM registration is particularly useful for processing of data acquired on OpenSPIM. Detailed step-by-step tutorials are available on the OpenSPIM wiki.

The pipeline is relatively linear as described above, we highlight the steps where alternative routes exist.


How do I view fused, saved output image(s)

The fused images will be saved in the output directory of the dataset as a collection of two-dimensional planes. The created output images can be viewed for example with Plugins->Image5D->Virtual Image 5D Opener or via the Plugins->LOCI->Bio-Formats Importer (check the option Group files with similar names).

Downloading example dataset

There is a 7-angle SPIM dataset of Drosophila available here. The cropping parameters pre-set in the plugin fit this dataset, only the appropriate folder has to be defined.

System requirements

Multi-view SPIM datasets are typically rather large, therefore it is recommended to use the registration plugin on a computer with a lot of RAM. The minimal requirement for the example dataset is at least 4Gb of memory however we recommend an 16Gb+ system. You may need to increase the Fiji memory limit by going to Edit->Options->Memory & Threads.

Cluster processing

See dedicated page describing how to process SPIM data from Lighsheet.Z1 on the MPI-CBG cluster.